Dictionary version 3.5

Description:

The program is intended for language learning. You can store, browse, search, export/import a print the vocabulary. Program can test your knowledge even according to your successfulness in past testings. The program contains two full dictionaries (Cambridge English 1. & 2.). New version also includes program Agent for displaying test dialog in predefined intervals.

You can download a freeware version of the program on our Download page.

Controls:

If you start the program then the standard dictionary file will be opened. If you want to open a different dictionary, then use menu File. The program contains two different views. The first view displays all the vocabulary in the form of a list. This view is very useful for quick browsing. When you click on a word in this view, then at the bottom of the screen (in the status bar) you will see how successful you are with this word. You can also use this view to quickly find a word by pressing a leading character on the keyboard (the dictionary must be sorted). The other view is the view where you see just one word on the screen, but you see all the details. This view is used whenever you enter new words, modify or delete the existing words. You can work with the whole dictionary or with just a subset. If you want you can select (Select item in menu) just one lesson and then work with just words from this lesson or you can select all words you are not very successful with. Beside this you can use search feature (Find item in menu) to find specific words in the dictionary. You can also sort the dictionary by every possible way. When you think that you are ready, you can try to test the vocabulary. Program will randomly display words from the current selection. According to your answers the program will automatically update how successful you are with every word. At the status bar you will see the overall successfulness. If you want to reset the success then use menu item Reset Success from Tools menu. You can set labels, fonts and many other for each dictionary in Tools menu. Program allows you to print the dictionary as well as import and export the vocabulary.
There is a new program Learning Agent which displays a testing dialog in predefined intervals. All the agent parameters can be set in Agent tab in program parameters dialog (Preferences).

Problems:

If the program can't open the data file and you are sure that the file is present, then you probably don't have installed the recent version of Microsoft data access environment on your computer. This environment called Microsoft DAO must be installed (it already is if you use Microsoft Access). You can download the environment from our download page.

If you can't run the program, then you probably don't have installed the recent version of Microsoft MFC library. You can download the library from our download page.

Frequently Asked Questions (FAQ):

Where can I get additional dictionaries?
There are dictionaries Cambridge English 1 and Cambridge English 2 included with the program. I have entered the words manually into the program from the books. I am just studying German language and though it is very possible that German dictionaries will be available in some time. If you want other dictionary, then try to find it on the Internet and then Import it to the program or create it by yourself.

How can I create a dictionary?
Start the program Dictionary and choose item New from File menu. Enter a name of a created dictionary and click on Save. This will create a dictionary file on the disc. For entering the words into this dictionary file choose item Add New from Dictionary menu.

I have downloaded the program from Internet, but after installing the program I can't start it! It shows an error message. What's wrong?
The program is created so that it is as small as possible. The program uses MFC library but this is not included with the program (because most of the computers already contain this library). If your computer doesn't contain the current version of this library, then the system shows an error message after starting the program. Download the file vcredist.exe from download page and install it.

The program starts but immediately shows an error message that the file can't be opened! What's wrong?
The program uses Microsoft Data Access Objects environment (DAO) for accessing data. If the environment is not installed on your computer then this or similar message is displayed. Download the file dao.exe from download page and install it. In the first step of the install check JetEngine (you can uncheck ODBC Direct) and in the second step check XBase (you can uncheck all other options). After that the installation would start. After a while a dialog would ask you to enter a third install disc - just click on Ok to proceed and finish the installation.

Support Information:

New version 3.5 has improved test engine. It currently doesn't repeat already answered words.

Information about previous version 3.0: The program has several updates. The browse view has been changed so that it better displays different fonts. In testing mode it is possible to hide remarks and pronunciation. The same functionality is in Agent program. The version also corrected problem with saving preferences.

Information about previous version 2.5: The program has one new feature. In the browse view you can quickly browse the records by pressing a keyboard key. The program finds the first record beginning with the appropriate character (the dictionary must be ordered). The program in this version has a feature that if you specify a selection of records that is not valid (there is no record for your new selection) then the current selection remains (the previous version selected no record).

Information about previous version 2.5: The program newly includes the program Agent. This program displays dialog for testing in predefined intervals. All Agent parameters can be set in tab Agent in dialog with program parameters.

Information about previous version 2.0: Program is completely rewritten. It contains two different views - one view lists words and phrases in columns and the second view displays details. You can configure the program for different languages (column labels, dictionary title, column fonts and character sets). Program can import and export the dictionary to many different formats. You can use many different modes for searching and sorting the dictionary. You don't have to work with the whole dictionary, but you can select a subset of the dictionary to work with. Once you think you have learned the dictionary, you can let yourself to be tested. The program displays how successful you are with every word in the dictionary. This means, that you can be tested only from the words you don't know well yet.
The format of the dictionary files has been changed and so you can't use the MDB files from the version 1.5. If you need to open the previous version dictionary, then open it in Dictionary 1.5 and export it to text file. Then you can import this text file into Dictionary 2.0.

Information about previous version 1.5: It is finally here. We have ported our Dictionary program in new version 1.5 to the English language. This dictionary supports multiple dictionary files (the files are in MS Access format and so you can do some changes in Access - you CAN'T change the structure of the database of course). The dictionary also supports searching, browsing as well as printing of part of your dictionary. If you think you know the words good enough you can try to test your knowledge by entering test mode.